{DELAY} MICHIGAN MVR'S

Incident Report for Data

Resolved

This incident has been resolved.
Posted Jun 17, 2025 - 08:50 CST

Identified

Michigan vehicle and driver records will be down from 6/13 at 5pm CT thru 6/15 at 7pm CT for an update to their current system.
Posted Jun 12, 2025 - 08:45 CST