MI - Kent county

Incident Report for Data

Update

District Court public access is still down. There is currently no eta for restoration and court clerk assistance is required. Please expect delays.
Posted Feb 18, 2025 - 11:09 CST

Update

We are continuing to work on a fix for this issue.
Posted Dec 27, 2024 - 08:55 CST

Identified

District Court public access is down. There is currently no eta for restoration.
Posted Dec 18, 2024 - 08:49 CST