GA - Clayton

Incident Report for Data

Update

Continued clerk delays due to staffing issues. The turnaround for records and possible records is averaging 8-10 business days.
Posted Feb 18, 2025 - 11:07 CST

Identified

Staffing shortages are occuring. Expect delays in processing time of 10 days for searches with records and possible records.
Posted Dec 27, 2024 - 09:00 CST