CA - ALL county courts closed on 3/31 for Cesar Chavez Day

Incident Report for Data

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 08:20 CST

Investigating

ALL county courts are closed on Monday, 3/31 for Cesar Chavez Day
Posted Mar 31, 2025 - 07:40 CST