Access to the online index has been restored. Please expect delays as the backlog is worked through.
Posted Mar 26, 2025 - 08:42 CST
Monitoring
The Cleveland Municipal court remains closed with their online index inaccessible and no ETA on when services will be restored. Please expect delays.
Posted Mar 12, 2025 - 13:16 CST
Identified
The Cleveland Municipal court will be closed today, 3/3, as the court is still recovering from a recent cyber attack. No ETA at this time for system restoration. Please expect delays.