We are continuing to monitor for any further issues.
Posted Jun 10, 2025 - 11:42 CST
Update
A public access terminal is now available in Franklin, however, court staff are limiting use to one 1hr appointment per researcher per day. Please continue to expect delays on all Franklin orders at this time.
Posted Jun 06, 2025 - 06:37 CST
Update
KY-Franklin; court is currently open at a temporary location with no Public Access Terminal available to search. Court clerks have stated they are working on restoring access to a PAT but cannot provide an ETA at this time. Please continue to expect extended delays on all Franklin orders until PAT access has been restored.
Posted Apr 25, 2025 - 09:06 CST
Monitoring
KY-Pike; will be closed 23rd-26th and will reopen on April 28th.
Posted Apr 22, 2025 - 09:38 CST
Update
KY- Franklin (open) KY-Hardin (open) KY- Bullitt (open)
Posted Apr 22, 2025 - 09:33 CST
Identified
Courts closed due to flooding. Please expect delays.